archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / gala / trunk / PKGBUILD
blobfcd49eae38acae5d4ecd639f07318d259395ae3d
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=gala
4 pkgver=7.0.3
5 pkgrel=1
6 pkgdesc='The Pantheon Window Manager'
7 arch=(x86_64)
8 url=https://github.com/elementary/gala
9 license=(GPL3)
10 groups=(pantheon)
11 depends=(
12   atk
13   bamf
14   cairo
15   gdk-pixbuf2
16   glib2
17   gnome-desktop
18   gtk3
19   json-glib
20   libcanberra
21   libdrm
22   libgee
23   libgexiv2
24   libgl
25   libgranite.so
26   libx11
27   libxcomposite
28   libxdamage
29   libxext
30   libxfixes
31   libxi
32   libxrandr
33   libxtst
34   mesa
35   mutter
36   pango
37   plank
38   wayland
40 makedepends=(
41   cmake
42   git
43   gnome-common
44   intltool
45   meson
46   vala
48 provides=(libgala.so)
49 _tag=abf2874aa47175a0459000c985defb87414d8372
50 source=(git+https://github.com/elementary/gala.git#tag=${_tag})
51 b2sums=(SKIP)
53 pkgver() {
54   cd gala
55   git describe --tags | sed 's/-/.r/; s/-g/./'
58 build() {
59   arch-meson gala build
60   meson compile -C build
63 package() {
64   meson install -C build --destdir "${pkgdir}"
67 # vim:set sw=2 sts=-1 et: