1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Vesa Kaihlavirta <vesa@archlinux.org>
3 # Contributor: Thomas Dziedzic <gostrc@gmail.com>
5 # Special note for devs looking to upgrade this package:
6 # ghc places a unique hash for each library when it is built.
7 # Libraries depend on versions specified by those hashes.
8 # This implies that all libraries need to be rebuilt when ghc is rebuilt.
13 pkgname=(ghc-libs ghc ghc-static)
16 pkgdesc='The Glasgow Haskell Compiler'
18 url='https://www.haskell.org/ghc/'
20 makedepends=('ghc-static' 'perl' 'libxslt' 'docbook-xsl' 'python-sphinx' 'haskell-hscolour'
21 'texlive-bin' 'texlive-latexextra' 'ttf-dejavu' 'alex' 'happy' 'time' 'numactl' 'llvm14')
22 source=("https://downloads.haskell.org/~ghc/$pkgver/$pkgbase-${pkgver}-src.tar.xz"
23 ghc-sphinx-6.patch::https://gitlab.haskell.org/ghc/ghc/-/commit/00dc51060881df81258ba3b3bdf447294618a4de.patch
24 ghc-rebuild-doc-index.hook ghc-register.hook ghc-unregister.hook)
25 noextract=("$pkgbase-${pkgver}-src.tar.xz")
26 sha512sums=('32994c7d2b8f47bae604cd825bfcf9c788d79ce26d1d5f58bd73a7093e11ae6c3c17b31dc0c9e454dbf67ca169b942f92213c388d615768cae86055bf6094dee'
27 '7a79a5e9591b1ddd78fa349526a85cf9fee64db80639dcf1f3d6edef422fd4454222aedf5581e21489a20d748656265a40e7645004e4d5220280f6214c568e64'
28 'd69e5222d1169c4224a2b69a13e57fdd574cb1b5932b15f4bc6c7d269a9658dd87acb1be81f52fbcf3cb64f96978b9943d10cee2c21bff0565aaa93a5d35fcae'
29 '5f659651d8e562a4dcaae0f821d272d6e9c648b645b1d6ab1af61e4dd690dc5a4b9c6846753b7f935963f001bb1ae1f40cd77731b71ef5a8dbc079a360aa3f8f'
30 '3bdbd05c4a2c4fce4adf6802ff99b1088bdfad63da9ebfc470af9e271c3dd796f86fba1cf319d8f4078054d85c6d9e6a01f79994559f24cc77ee1a25724af2e6')
33 # Need to extract this tarball with a UTF-8 locale instead of a chroot's "C"
34 # locale; otherwise we get:
35 # bsdtar: Pathname can't be converted from UTF-8 to current locale.
36 LANG=en_US.UTF-8 bsdtar xf $pkgbase-${pkgver}-src.tar.xz
39 patch -p1 -i ../ghc-sphinx-6.patch
41 # Suppress warnings for newer LLVM. LlvmMaxVersion is non-inclusive and currently GHC
42 # doesn't work with LLVM 15: https://gitlab.haskell.org/ghc/ghc/-/merge_requests/8999
43 sed -i 's/LlvmMaxVersion=13/LlvmMaxVersion=15/' configure.ac
45 # Temporary hack to use LLVM 14 for bootstrapping during LLVM 15 rebuild.
46 export PATH="/usr/lib/llvm14/bin/:$PATH"
48 cp mk/build.mk{.sample,}
49 sed -i '1iBuildFlavour = perf-llvm' mk/build.mk
59 --docdir=/usr/share/doc/ghc \
60 --with-system-libffi \
61 --with-ffi-includes=$(pkg-config --variable=includedir libffi)
65 package_ghc-static() {
66 pkgdesc='The Glasgow Haskell Compiler - Static Libraries and Documentation'
71 make DESTDIR="$pkgdir" -j1 install
73 mv "$pkgdir"/usr/lib/ghc-$pkgver/package.conf.d "$srcdir"/static-package.conf.d
74 find "$pkgdir"/usr/lib ! \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -type f -delete
75 find "$pkgdir"/usr/lib -type d -empty -delete
76 mv "$srcdir"/static-package.conf.d "$pkgdir"/usr/lib/ghc-$pkgver/
77 rm -r "$pkgdir"/usr/bin "$pkgdir"/usr/share/man
79 install -Dm644 "$srcdir"/ghc-rebuild-doc-index.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-rebuild-doc-index.hook
83 pkgdesc='The Glasgow Haskell Compiler'
84 depends=('gcc' 'ghc-libs' 'llvm14')
85 provides=('haskell-haddock=2.25.1'
87 'haskell-hpc-bin=0.68'
88 'haskell-hsc2hs=0.68.7')
89 replaces=('haskell-haddock'
94 provides+=("haskell-ghc=$pkgver")
95 replaces+=("haskell-ghc")
98 make DESTDIR="$pkgdir" -j1 install
101 find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -delete
103 # ghc-pkg is in ghc-libs
104 rm "$pkgdir"/usr/lib/ghc-$pkgver/bin/ghc-pkg*
105 rm "$pkgdir"/usr/bin/ghc-pkg*
106 (cd "$pkgdir"/usr/lib/ghc-$pkgver; rm -r !(bin|ghc-$pkgver))
108 # docs moved to ghc-static
109 rm -r "$pkgdir"/usr/share/doc
111 install -Dm644 utils/completion/ghc.bash \
112 "$pkgdir/usr/share/bash-completion/completions/ghc"
116 pkgdesc='The Glasgow Haskell Compiler - Dynamic Libraries'
117 install='ghc.install'
118 depends=('gmp' 'libffi' 'numactl' 'perl')
119 provides=('haskell-array=0.5.4.0'
120 'haskell-base=4.15.1.0'
121 'haskell-binary=0.8.8.0'
122 'haskell-bytestring=0.10.12.1'
123 'haskell-cabal=3.4.1.0'
124 'haskell-containers=0.6.4.1'
125 'haskell-deepseq=1.4.5.0'
126 'haskell-directory=1.3.6.2'
127 'haskell-exceptions=0.10.4'
128 'haskell-filepath=1.4.2.1'
129 'haskell-ghc-bignum=1.1'
130 'haskell-ghc-boot=9.0.2'
131 'haskell-ghc-boot-th=9.0.2'
132 'haskell-ghc-compact=0.1.0.0'
133 'haskell-ghc-heap=9.0.2'
134 'haskell-ghc-prim=0.7.0'
135 'haskell-haskeline=0.8.2'
136 'haskell-hpc=0.6.1.0'
137 'haskell-integer-gmp=1.1'
138 'haskell-libiserv=9.0.2'
140 'haskell-parsec=3.1.14.0'
141 'haskell-pretty=1.1.3.6'
142 'haskell-process=1.6.13.2'
143 'haskell-stm=2.5.0.0'
144 'haskell-template-haskell=2.17.0.0'
145 'haskell-terminfo=0.4.1.5'
146 'haskell-text=1.2.5.0'
148 'haskell-transformers=0.5.6.2'
149 'haskell-unix=2.7.2.2'
150 'haskell-xhtml=3000.2.2.1'
151 'haskell-ghc-pkg=9.0.2')
152 replaces=('haskell-array'
164 'haskell-ghc-boot-th'
165 'haskell-ghc-compact'
170 'haskell-integer-gmp'
177 'haskell-template-haskell'
181 'haskell-transformers'
186 provides+=("haskell-ghci=$pkgver")
187 conflicts+=('haskell-ghci')
191 make DESTDIR="$pkgdir" -j1 install
194 find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.o" -o -name "*.p_o" -o -name "*.p_hi" -o -name "*.hi" \) -delete
196 # ghc library and other exes are in the ghc package
197 rm -r "$pkgdir"/usr/lib/ghc-$pkgver/ghc-$pkgver
198 (cd "$pkgdir"/usr/lib/ghc-$pkgver/bin; rm !(ghc-pkg*))
199 (cd "$pkgdir"/usr/bin; rm !(ghc-pkg*))
201 # docs moved to ghc-static
202 rm -r "$pkgdir"/usr/share/{man,doc}
204 install -Dm644 "$srcdir"/ghc-register.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-register.hook
205 install -Dm644 "$srcdir"/ghc-unregister.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-unregister.hook
207 install -dm755 "$pkgdir"/usr/share/haskell/{register,unregister}
209 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE