archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / gpodder / repos / community-any / PKGBUILD
blob3a315090a872cf552263d62f10cff5b319382de5
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Jan Magnus Brevik <janmbrevik@gmail.com>
4 pkgname=gpodder
5 pkgver=3.11.1
6 pkgrel=2
7 pkgdesc='Podcast client written in Python using GTK'
8 arch=('any')
9 url='https://gpodder.github.io/'
10 license=('GPL3')
11 depends=('gtk3' 'python-cairo' 'dbus-python' 'python-gobject' 'python-mygpoclient'
12          'python-podcastparser' 'python-requests')
13 makedepends=('intltool')
14 optdepends=('libnotify: Gtk+ Desktop Notifications extension'
15             'python-mutagen: Tag downloaded files, Remove cover art from OGG files extensions'
16             'webkit2gtk: HTML show notes'
17             'youtube-dl: Youtube-dl extension')
18 source=("https://github.com/gpodder/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
19 sha256sums=('c24fb3ef70b5acf43c07e6dd4e78c309e1cbacff621eb59f73c137b9597c6e87')
21 prepare() {
22   cd $pkgname-$pkgver
23   # Use gio open directly instead of xdg-open
24   sed -i "s/\['xdg-open', filename\]/['gio', 'open', filename]/" src/gpodder/util.py
27 build() {
28   cd $pkgname-$pkgver
29   make messages
32 package() {
33   cd $pkgname-$pkgver
34   make DESTDIR="$pkgdir" install