archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / gtkd / trunk / PKGBUILD
blobe60105647acc2fa603ca43acb7fff14b8dd73af9
1 # Maintainer: Dan Printzell <wild@archlinux.org>
2 # Maintainer: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
3 # Contributor: Severen Redwood <severen@shrike.me>
4 # Contributor: Robert Welin <robert.welin@gmail.com>
5 # Contributorr: dsboger <https://github.com/dsboger>
7 pkgname=gtkd
8 pkgver=3.10.0
9 pkgrel=6
10 pkgdesc='D bindings for GTK+ and related libraries.'
11 arch=('x86_64')
12 url='https://gtkd.org'
13 license=('LGPL')
14 depends=('liblphobos' 'gtk3')
15 makedepends=('ldc')
16 optdepends=('pango' 'atk' 'gdk-pixbuf2' 'gtksourceview3' 'gstreamer' 'vte3' 'libpeas')
17 source=("GtkD-$pkgver.tar.gz::https://github.com/gtkd-developers/GtkD/archive/v$pkgver.tar.gz")
18 sha512sums=('1e75d6cbd278a065ce26b33320fe06cc7a30af8bd884c3c87abe799afaf9da8339d3c4470163b62ec8b70e8c540285b8c2c409c7b77423142a301f23ba37ff2e')
20 build() {
21     cd GtkD-$pkgver
22                 export _ldFlags="$(echo -ne $LDFLAGS | sed -e 's/ /,/g')"
24     make \
25         DC='ldc' \
26         LDFLAGS="-L=\"$_ldFlags\"" \
27         libdir='lib/' \
28         shared-{gtkd,gtkdgl,sv,gstreamer,vte,peas}
31 check() {
32     cd GtkD-$pkgver
34     make LDFLAGS='' test
37 package() {
38     cd GtkD-$pkgver
40     make \
41         prefix='/usr' \
42         libdir='lib/' \
43         DESTDIR="$pkgdir" \
44         install-{shared,headers}-{gtkd,gtkdgl,gtkdsv,gstreamer,vte,peas}