archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-adjunctions / trunk / PKGBUILD
blob639f823a461144f53bd9327be2bdd337a2b7c544
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=adjunctions
5 pkgname=haskell-adjunctions
6 pkgver=4.4.2
7 pkgrel=47
8 pkgdesc="Adjunctions and representable functors"
9 url="https://github.com/ekmett/adjunctions/"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-comonad' 'haskell-contravariant' 'haskell-distributive' 'haskell-free'
13          'haskell-profunctors' 'haskell-semigroupoids' 'haskell-tagged'
14          'haskell-transformers-compat' 'haskell-void')
15 makedepends=('ghc' 'uusi' 'haskell-generic-deriving' 'haskell-hspec')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('3785268bd3971f16dc0f2517556127590e8fb87f8e2cb8dfc74c356a8496ac1f2a46115097c4750d1d92eb21f25e0beec0a248d3442da2c8f6eb9da8cc4c51e3')
19 prepare() {
20     cd $_hkgname-$pkgver
21     uusi -d semigroups $_hkgname.cabal
24 build() {
25     cd $_hkgname-$pkgver
26     
27     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
29         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
30     runhaskell Setup build $MAKEFLAGS
31     runhaskell Setup register --gen-script
32     runhaskell Setup unregister --gen-script
33     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38     cd $_hkgname-$pkgver
39     runhaskell Setup test --show-details=direct
42 package() {
43     cd $_hkgname-$pkgver
44     
45     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47     runhaskell Setup copy --destdir="$pkgdir"
48     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE