1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-cracknum
8 pkgdesc="Crack various integer and floating-point data formats"
9 url="https://github.com/LeventErkok/crackNum"
12 depends=('ghc-libs' 'haskell-libbf' 'haskell-sbv' 'haskell-tasty' 'haskell-tasty-golden')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('1721a70cbebb89cf795882d1e3635e4d4aac5971bb41a2817c188257e459d558809059efc1de0840830f2aa753fa3b54d74ad8da6cbbd3766f6a089f592912d0')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup copy --destdir="$pkgdir"
30 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
31 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE