archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-cracknum / repos / community-x86_64 / PKGBUILD
blob1e1bbeb434ffcefe4e75fe480a94a5c1eec50871
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=crackNum
5 pkgname=haskell-cracknum
6 pkgver=3.2
7 pkgrel=186
8 pkgdesc="Crack various integer and floating-point data formats"
9 url="https://github.com/LeventErkok/crackNum"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-libbf' 'haskell-sbv' 'haskell-tasty' 'haskell-tasty-golden')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('1721a70cbebb89cf795882d1e3635e4d4aac5971bb41a2817c188257e459d558809059efc1de0840830f2aa753fa3b54d74ad8da6cbbd3766f6a089f592912d0')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
26 package() {
27     cd $_hkgname-$pkgver
29     runhaskell Setup copy --destdir="$pkgdir"
30     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
31     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE