1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ghc-exactprint
4 pkgname=haskell-ghc-exactprint
7 pkgdesc="ExactPrint for GHC"
8 url="https://github.com/alanz/ghc-exactprint.git"
11 depends=('ghc-libs' 'haskell-free' 'haskell-ghc-paths' 'haskell-syb')
12 makedepends=('ghc' 'haskell-diff' 'haskell-hunit' 'haskell-filemanip' 'haskell-silently')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha512sums=('a269d270464ee34493117e672c819eefe369bb88bd6043284631f67b3c711e6559f7d6352da2080bc65749767305ea75b9bc43e594bdfcd81ea6cb02986a8bff')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
25 runhaskell Setup build $MAKEFLAGS
26 runhaskell Setup register --gen-script
27 runhaskell Setup unregister --gen-script
28 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 runhaskell Setup test --show-details=direct
40 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42 runhaskell Setup copy --destdir="$pkgdir"
43 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE