archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-ghc-exactprint / trunk / PKGBUILD
blob0f4b2df5d095aee92f78e7a6ab7a38d98b8ab345
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ghc-exactprint
4 pkgname=haskell-ghc-exactprint
5 pkgver=0.6.4
6 pkgrel=167
7 pkgdesc="ExactPrint for GHC"
8 url="https://github.com/alanz/ghc-exactprint.git"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-free' 'haskell-ghc-paths' 'haskell-syb')
12 makedepends=('ghc' 'haskell-diff' 'haskell-hunit' 'haskell-filemanip' 'haskell-silently')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha512sums=('a269d270464ee34493117e672c819eefe369bb88bd6043284631f67b3c711e6559f7d6352da2080bc65749767305ea75b9bc43e594bdfcd81ea6cb02986a8bff')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE