archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-gi-dbusmenu / trunk / PKGBUILD
blobe7b36259831622fd040b3f4f857cc93521d3e57e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=gi-dbusmenu
4 pkgname=haskell-gi-dbusmenu
5 pkgver=0.4.11
6 pkgrel=45
7 pkgdesc="Dbusmenu bindings"
8 url="https://github.com/haskell-gi/haskell-gi"
9 license=("LGPL2_1")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-gi-glib' 'haskell-gi-gobject' 'haskell-gi' 'haskell-gi-base'
12          'haskell-gi-overloading' 'libdbusmenu-glib')
13 makedepends=('ghc' 'gobject-introspection')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('8d6908739396a3b2c2e42b5844fe0dda890fa1d57b8ac4c209f6241aac97bf1a')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie' 
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE