1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Abstraction over creating network connections with SOCKS5 and TLS"
8 url="https://github.com/glguy/irc-core"
11 depends=('ghc-libs' 'haskell-hsopenssl' 'haskell-hsopenssl-x509-system' 'haskell-async'
12 'haskell-attoparsec' 'haskell-network')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('2be6e6af7c03c4b5592567eaaeb4dacdf10b0f94779df0c1180fc94c249ff90a')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE