archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-hookup / trunk / PKGBUILD
blob7a6deabd753162bf5eb9d9ddee4a147e71cf2b55
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hookup
4 pkgname=haskell-hookup
5 pkgver=0.7
6 pkgrel=29
7 pkgdesc="Abstraction over creating network connections with SOCKS5 and TLS"
8 url="https://github.com/glguy/irc-core"
9 license=("ISC")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-hsopenssl' 'haskell-hsopenssl-x509-system' 'haskell-async'
12          'haskell-attoparsec' 'haskell-network')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('2be6e6af7c03c4b5592567eaaeb4dacdf10b0f94779df0c1180fc94c249ff90a')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie' 
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE