archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-miniutter / repos / community-x86_64 / PKGBUILD
blob660c4f85bfcca3fa5684ee1fab3409e1ddb5ffbf
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=miniutter
4 pkgname=haskell-miniutter
5 pkgver=0.5.1.2
6 pkgrel=24
7 pkgdesc="Simple English clause creation from arbitrary words"
8 url="https://github.com/Mikolaj/miniutter"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-minimorph')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-test-framework' 'haskell-test-framework-hunit')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('a68284c7731ec9430e1b4393155b8096e8c8a74861ec1e8c66286ee8655ab713')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-miniutter --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' 
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE