archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-network-run / repos / community-x86_64 / PKGBUILD
blob195731491ad2b7e166ef9dc78576fe3166a70f17
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=network-run
4 pkgname=haskell-network-run
5 pkgver=0.2.4
6 pkgrel=101
7 pkgdesc="Simple network runner library"
8 url="https://github.com/kazu-yamamoto/network-run"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-network')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('f415c619eeb34a18493dfcd634049c7a1da1b02615e1387b0096c80126af6d70')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE