archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-system-fileio / repos / community-x86_64 / PKGBUILD
blobfcc3d0e2bd90d3cf3a3458d38fe71edaadfa3cb3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=system-fileio
5 pkgname=haskell-system-fileio
6 pkgver=0.3.16.4
7 pkgrel=221
8 pkgdesc="Consistent filesystem interaction across GHC versions"
9 url="https://github.com/fpco/haskell-filesystem"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-system-filepath")
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('68530cd11b25aa8a05967d3f51091ea57a5be138b672bd5373918163281c55a91b60dea03bdd22bcd4ba1d6bb26e2ed14660ce55bbdaf2737d2dd2b7e608d698')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
37     rm -f "${pkgdir}/usr/share/doc/${pkgname}/license.txt"