archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-tar-conduit / trunk / PKGBUILD
bloba8687afd086cc2f20188cf06a0f5c7c343dd6855
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=tar-conduit
4 pkgname=haskell-tar-conduit
5 pkgver=0.3.2
6 pkgrel=379
7 pkgdesc="Extract and create tar files using conduit for streaming"
8 url="https://github.com/snoyberg/tar-conduit"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-conduit' 'haskell-safe-exceptions')
12 makedepends=('ghc' 'haskell-conduit-extra' 'haskell-hspec' 'haskell-quickcheck' 'haskell-weigh')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('18efa362953641092ee5b4f65b32a3337af077608487e02421cf6427209592654b3b2d15f9b21835f4596434b65aa9a1f80b9f3408050c09b57f6be5cd2c73f7')
16 prepare() {
17     cd $_hkgname-$pkgver
18     sed -i '/conduit-combinators/d' $_hkgname.cabal
21 build() {
22     cd $_hkgname-$pkgver    
23     
24     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
41     
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE