archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-zenc / trunk / PKGBUILD
blobfc83410431930e4152bf7c452a8e50d2c9a9e5ae
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=zenc
4 pkgname=haskell-zenc
5 pkgver=0.1.2
6 pkgrel=127
7 pkgdesc="GHC style name Z-encoding and Z-decoding"
8 url="https://github.com/dagit/zenc"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'uusi' 'haskell-hedgehog' 'haskell-hspec' 'haskell-hspec-hedgehog')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('cd1d7feef5c3b23180e1402d057572a9619cff4d2c880a9ba1a746c15d25d1dc0add1fc7b7821ae48722c40bca0b26011f2d0df918a18fd011c4098483ce9668')
16 prepare() {
17     cd $_hkgname-$pkgver
18     uusi -u hedgehog -u hspec $_hkgname.cabal
21 build() {
22     cd $_hkgname-$pkgver    
23     
24     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
41     
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE