archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / highway / trunk / PKGBUILD
blob3489473327ce62cd1172b58ec3fceca27615e72a
1 # Maintainer: Daniel Bermond <dbermond@archlinux.org>
3 pkgname=highway
4 pkgver=1.0.4
5 pkgrel=1
6 pkgdesc='A C++ library for SIMD (Single Instruction, Multiple Data)'
7 arch=('x86_64')
8 url='https://github.com/google/highway/'
9 license=('Apache')
10 depends=('gcc-libs')
11 makedepends=('cmake' 'gtest')
12 source=("https://github.com/google/highway/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
13 sha256sums=('faccd343935c9e98afd1016e9d20e0b8b89d908508d1af958496f8c2d3004ac2')
15 build() {
16     cmake -B build -S "${pkgname}-${pkgver}" \
17         -G 'Unix Makefiles' \
18         -DCMAKE_BUILD_TYPE:STRING='None' \
19         -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
20         -DBUILD_SHARED_LIBS:BOOL='ON' \
21         -DHWY_SYSTEM_GTEST:BOOL='ON' \
22         -Wno-dev
23     cmake --build build
26 check() {
27     ctest --test-dir build --output-on-failure
30 package() {
31     DESTDIR="$pkgdir" cmake --install build