archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / i3status-rust / repos / community-x86_64 / PKGBUILD
blob6171e0efd8b3f0a9062744a53fa3b47262ff2025
1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
2 # Contributor: Daniel M. Capella <polyzen@archlinux.org>
3 # Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
5 pkgname=i3status-rust
6 pkgver=0.31.5
7 pkgrel=1
8 pkgdesc='Resourcefriendly and feature-rich replacement for i3status, written in pure Rust'
9 arch=('x86_64')
10 url='https://github.com/greshake/i3status-rust'
11 license=('GPL3')
12 depends=('libpulse' 'lm_sensors')
13 makedepends=('rust' 'pandoc')
14 optdepends=('alsa-utils: for the volume block'
15             'bluez: for the bluetooth block'
16             'fakeroot: for the pacman block to show pending updates'
17             'kdeconnect: for the kdeconnect block'
18             'powerline-fonts: for all themes using the Powerline arrow char'
19             'pulseaudio: for the volume block'
20             'speedtest-cli: for the speedtest block'
21             'ttf-font-awesome: for the awesome icons'
22             'upower: for the battery block')
23 source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/greshake/i3status-rust/archive/refs/tags/v${pkgver}.tar.gz")
24 b2sums=('8d38fcdbc3bdb32e5a3ea0a09e27ee5e0677806dfffc64afdbc0d2ecd1f3e7f19c38c7c264525c7889c10356772c955a381469dcfdb9cd88b4abb9573e177166')
26 prepare() {
27   cd ${pkgname}-${pkgver}
28   cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
32 build() {
33   cd ${pkgname}-${pkgver}
34   export RUSTUP_TOOLCHAIN=stable
35   export CARGO_TARGET_DIR=target
36   cargo build --release --locked --features 'pulseaudio maildir'
37   cargo xtask generate-manpage
40 package() {
41   cd ${pkgname}-${pkgver}
42   install -Dm755 -t "${pkgdir}"/usr/bin target/release/i3status-rs
43   install -Dm644 -t "${pkgdir}"/usr/share/man/man1 man/i3status-rs.1
45   for icon in files/icons/*.toml; do
46     install -Dm644 -t "${pkgdir}"/usr/share/${pkgname}/icons "${icon}"
47   done
49   for theme in files/themes/*.toml; do
50     install -Dm644 -t "${pkgdir}"/usr/share/${pkgname}/themes "${theme}"
51   done
53   for example in examples/*.toml; do
54     install -Dm644 -t "${pkgdir}"/usr/share/doc/${pkgname}/examples/ ${example}
55   done