archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / kiwix-desktop / repos / community-x86_64 / PKGBUILD
blobdcaabd9517739974d056613092909cba57f6abb2
1 # Maintainer: Justin Kromlinger <hashworks@archlinux.org>
3 pkgname=kiwix-desktop
4 pkgver=2.3.1
5 pkgrel=2
6 pkgdesc="Offline reader for Web content, especially intended to make Wikipedia available offline"
7 url="https://github.com/kiwix/kiwix-desktop"
8 arch=("x86_64")
9 license=("GPL3")
10 depends=("qt5-base" "qt5-webengine" "libkiwix" "aria2")
11 makedepends=("qt5-tools")
12 source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
13 sha256sums=('799d887efd6a855aefe27452b1e3c02da3b443b1ea19c961b7d58dc55e019342')
15 build() {
16         cd "${pkgname}-${pkgver}"
17         export CFLAGS+=" ${CPPFLAGS}"
18         export CXXFLAGS+=" ${CPPFLAGS}"
19         qmake PREFIX="/usr"
20         make
23 package() {
24         cd "${pkgname}-${pkgver}"
25         install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
26         make INSTALL_ROOT="$pkgdir/" install