archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / libxisf / trunk / PKGBUILD
blob799d4a11fa26a694c418da98521d061c205cd7a7
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=libxisf
4 pkgver=0.2.3
5 pkgrel=2
6 pkgdesc='Library to load and write XISF format from PixInsight'
7 url='https://gitea.nouspiro.space/nou/libXISF'
8 license=(GPL3)
9 arch=(x86_64)
10 depends=(zlib lz4 pugixml)
11 makedepends=(cmake)
12 source=($pkgname-$pkgver.tar.gz::https://gitea.nouspiro.space/nou/libXISF/archive/v$pkgver.tar.gz)
13 sha256sums=('5574d850afd158f949089bdeb9cf52b814023d77c798ed2f2030828b17f471fc')
15 build() {
16   cmake -B build -S $pkgname \
17     -DCMAKE_INSTALL_PREFIX=/usr \
18     -DUSE_BUNDLED_LIBS=OFF
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build