archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / linuxdoc-tools / trunk / PKGBUILD
blob16f9943ca001fa1dd07669396fdb3ba67dc65734
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: David Ell <david at bytesizebits dot net>
4 pkgname=linuxdoc-tools
5 pkgver=0.9.82
6 pkgrel=2
7 pkgdesc="Convert LinuxDoc SGML source into other formats"
8 arch=('x86_64')
9 url="https://packages.debian.org/sid/linuxdoc-tools"
10 license=('GPL')
11 depends=('jade')
12 makedepends=('texlive-bin' 'texlive-core')
13 optdepends=('groff' 'texlive-bin')
14 source=(https://mirrors.edge.kernel.org/debian/pool/main/l/linuxdoc-tools/linuxdoc-tools_${pkgver}.orig.tar.gz)
15 sha256sums=('65e7c39eeabf464575bf7b5b4c0284ddd2c0e56b3e37e591c861708f1b00013d')
17 build() {
18   cd "$srcdir/$pkgname-$pkgver"
19   sed -i '/extern int yyleng;/d' rtf-fix/rtf2rtf.l
20   ./configure \
21     --prefix=/usr \
22     --mandir=/usr/share/man \
23     --with-texdir=/usr/share/texmf-dist/tex/linuxdoc
24   make
27 package() {
28   cd "$srcdir/$pkgname-$pkgver"
29   make DESTDIR="$pkgdir/" install