archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / navit / trunk / PKGBUILD
blobc0ee4119f3e0797128a62b1cee42496326ca2e96
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: TDY <tdy@archlinux.info>
3 # Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
4 # Contributor: Stefan Lohmaier <noneuss at gmail dot com
5 # Contributor: Thermionix <thermionix at gmail dot com>
7 pkgname=navit
8 pkgver=0.5.6
9 pkgrel=6
10 pkgdesc="Modular turn-by-turn car navigation system"
11 arch=('x86_64')
12 url="https://www.navit-project.org/"
13 license=('GPL')
14 depends=('dbus-glib' 'gpsd' 'gtk2' 'imlib2' 'sdl_image')
15 makedepends=('cmake' 'libxslt')
16 install=$pkgname.install
17 source=($pkgname-$pkgver.tar.gz::https://github.com/navit-gps/navit/archive/v$pkgver.tar.gz)
18 sha256sums=('043688e0b34504ca4ee80fb6a80895b938eae41e4031d0977dd30c20c20f1714')
20 prepare() {
21   cd $pkgname-$pkgver
22   sed -i 's/lib64/lib/' CMakeLists.txt 
25 build() {
26   cd $pkgname-$pkgver
27   cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_FLAGS="$CFLAGS -ffat-lto-objects" -DSAMPLE_MAP=FALSE -DDISABLE_QT=TRUE
28   make
31 package() {
32   cd $pkgname-$pkgver
33   make DESTDIR="$pkgdir" install