archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / neovim-lsp_signature / trunk / PKGBUILD
blobffe987e54a6083a49648be8eb0f5094cd42aa226
1 # Maintainer: David Runge <dvzrv@archlinux.org>
3 _upstream=lsp_signature.nvim
4 _name=lsp_signature
5 pkgname=neovim-lsp_signature
6 pkgver=0.2.0
7 pkgrel=3
8 pkgdesc="LSP signature hint as you type"
9 arch=(any)
10 url="https://github.com/ray-x/lsp_signature.nvim/"
11 license=(Apache)
12 groups=(neovim-plugins)
13 depends=(luajit neovim)
14 source=($pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz)
15 sha512sums=('c53a535136d28539e49e27da5fbfd3e78824c9b68184943d65e04b15308fab571340f9c1f388797821a9625496c2aea165f79d22c8799cf88160438e6a5b73e8')
16 b2sums=('e7b7044002e3413c4427fa8417ddab30ffb1a285530e126b8e5197024e486a3b55a35bedf05b9db8042acc9878c21e4348899e692d2685bf4818f69c671ea88c')
18 package() {
19   cd $_upstream-$pkgver
20   find doc lua -type f -exec install -vDm 644 {} "$pkgdir/usr/share/nvim/site/pack/dist/start/$_name/{}" \;
21   install -vDm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"