archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / nsz / trunk / PKGBUILD
blob261bcf64748bc3cfbcd531bcad47325e0c3c60d5
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Michael Armbruster <michael@armbrust.me>
4 pkgname=nsz
5 pkgrel=2
6 pkgver=4.2.1
7 pkgdesc='Nintendo Switch homebrew compatible NSP/XCI compressor/decompressor'
8 arch=(any)
9 url=https://github.com/nicoboss/nsz
10 license=(MIT)
11 depends=(
12   python-enlighten
13   python-pycryptodome
14   python-zstandard
16 makedepends=(
17   git
18   python-setuptools
20 optdepends=('python-kivy: GUI support')
21 _tag=ad358da6b640f69cf16541ebc691ac0a8cd76493
22 source=(git+https://github.com/nicoboss/nsz.git#tag=${_tag})
23 b2sums=(SKIP)
25 pkgver() {
26   cd nsz
27   git describe --tags
30 build() {
31   cd nsz
32   python setup.py build
35 package() {
36   cd nsz
37   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
40 # vim: ts=2 sw=2 et: