archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / opam / trunk / PKGBUILD
blob54b83a4636b869aa999b76d3ce3e0f4a7a4500a2
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Vincent B. <vb@luminar.eu.org>
4 pkgname=opam
5 pkgver=2.1.4
6 pkgrel=1
7 pkgdesc='OCaml package manager'
8 arch=(x86_64)
9 url='https://opam.ocaml.org/'
10 license=(GPL)
11 depends=(bubblewrap ocaml-compiler-libs unzip)
12 makedepends=(git)
13 optdepends=('darcs: For downloading packages with darcs'
14             'git: For downloading packages with git'
15             'mercurial: For downloading packages with mercurial'
16             'rsync: For downloading packages with rsync')
17 source=("https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz")
18 b2sums=('a95953a62ce2bb0c0d36512b7e393e10150b9bcc23d0847639511153a818db79d63969e6482d18e9316c18b0eac797727236382c5c5acaeacfe5a97b6de2548c')
20 build() {
21   cd opam-full-$pkgver
22   ./configure --prefix=/usr
23   make lib-ext all -j1 \
24     OCAMLC='ocamlc -unsafe-string' \
25     OCAMLOPT='ocamlopt -unsafe-string'
28 package() {
29   make -C opam-full-$pkgver DESTDIR="$pkgdir" install