archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-data-section / trunk / PKGBUILD
blob916e22238f2ee30aacfea8f8dfb7816e661c9bf0
1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-data-section
4 pkgver=0.200008
5 pkgrel=1
6 pkgdesc='read multiple hunks of data out of your DATA section'
7 arch=(any)
8 license=(PerlArtistic GPL)
9 options=(!emptydirs)
10 depends=('perl>=5.12' 'perl-mro-compat>=0.09' 'perl-sub-exporter>=0.979')
11 makedepends=('perl-extutils-makemaker>=6.78')
12 checkdepends=(perl-test-failwarnings)
13 url=https://metacpan.org/release/Data-Section
14 source=("https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Data-Section-$pkgver.tar.gz")
15 md5sums=(3e23aec25adece87533f7254f1b9c4a3)
16 sha512sums=(5fc8b25b1af8cdae5dca407bc039578e92bfc0b3bcfa2c01cdddf36ea30840f7eeeb336859a2e50719713c2675f2c1eb74c8832724d99ba4db92c47c65a860e3)
17 _ddir="Data-Section-$pkgver"
19 build()
21   cd "$srcdir/$_ddir"
22   export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
23   unset PERL5LIB PERL_MM_OPT
24   /usr/bin/perl Makefile.PL
25   make
28 check()
30   cd "$srcdir/$_ddir"
31   export PERL_MM_USE_DEFAULT=1
32   unset PERL5LIB
33   make test
36 package()
38   cd "$srcdir/$_ddir"
39   make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
42 # Local Variables:
43 # mode: shell-script
44 # sh-basic-offset: 2
45 # End:
46 # vim:set ts=2 sw=2 et: