archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-local-lib / trunk / PKGBUILD
blob8c5b6cc969062fb048b904517f5811df91e4c13c
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 pkgname=perl-local-lib
4 pkgver=2.000029
5 pkgrel=1
6 pkgdesc="Create and use a local lib/ for perl modules with PERL5LIB"
7 arch=('any')
8 url="https://search.cpan.org/dist/local-lib/"
9 license=('PerlArtistic' 'GPL')
10 depends=('perl')
11 options=('!emptydirs')
12 source=("https://search.cpan.org/CPAN/authors/id/H/HA/HAARG/local-lib-$pkgver.tar.gz")
13 sha256sums=('8df87a10c14c8e909c5b47c5701e4b8187d519e5251e87c80709b02bb33efdd7')
15 build() {
16   cd local-lib-${pkgver}
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd local-lib-${pkgver}
23   make test
26 package() {
27   cd local-lib-${pkgver}
28   make DESTDIR="$pkgdir" install