archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-sub-quote / repos / community-any / PKGBUILD
blob5834696f59b4bd4e4573694bc1af5719d61ab8d0
1 pkgname=perl-sub-quote
2 epoch=1
3 pkgver=2.006008
4 pkgrel=1
5 pkgdesc="efficient generation of subroutines via string eval"
6 arch=('any')
7 license=('PerlArtistic' 'GPL')
8 options=('!emptydirs')
9 depends=('perl')
10 makedepends=('perl-test-fatal>=0.010')
11 url='https://search.cpan.org/dist/Sub-Quote'
12 source=("https://search.cpan.org/CPAN/authors/id/H/HA/HAARG/Sub-Quote-$pkgver.tar.gz")
13 sha256sums=('94bebd500af55762e83ea2f2bc594d87af828072370c7110c60c238a800d15b2')
15 build() {
16   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
17       PERL_AUTOINSTALL=--skipdeps                            \
18       PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'"     \
19       PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
20       MODULEBUILDRC=/dev/null
22     cd "$srcdir/Sub-Quote-$pkgver"
23     perl Makefile.PL
24     make
25   )
28 check() {
29   cd "$srcdir/Sub-Quote-$pkgver"
30   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
31     make test
32   )
35 package() {
36   cd "$srcdir/Sub-Quote-$pkgver"
37   make install
39   find "$pkgdir" -name .packlist -o -name perllocal.pod -delete