archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / postgresql-ip4r / repos / community-x86_64 / PKGBUILD
bloba38270fdf17bf543c790fb243e488d196cf677dd
1 # Maintainer: daurnimator <daurnimator@archlinux.org>
3 pkgname=postgresql-ip4r
4 pkgver=2.4.1
5 pkgrel=3
6 pkgdesc="IPv4/v6 and IPv4/v6 range index type for PostgreSQL"
7 arch=('x86_64')
8 url="https://github.com/RhodiumToad/ip4r/"
9 license=('custom')
10 depends=('postgresql')
11 makedepends=('clang'
12              'llvm')
14 source=("$pkgname-$pkgver.tar.gz::https://github.com/RhodiumToad/ip4r/archive/$pkgver.tar.gz"
15         LICENSE)
16 sha256sums=('78b9f0c1ae45c22182768fe892a32d533c82281035e10914111400bf6301c726'
17             '6d61e1a86a5548ce790729a46efa621796d7b79d68e1e8bc92c29034100059a5')
19 build() {
20     cd "ip4r-$pkgver"
21     make
24 package() {
25     install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
27     cd "ip4r-$pkgver"
28     make DESTDIR="$pkgdir" install