archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-aioconsole / trunk / PKGBUILD
blob6fbc00e00f50d2f167ef85ee7ade20bdc4811bf0
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-aioconsole
4 pkgver=0.6.0
5 pkgrel=2
6 pkgdesc="Asynchronous console and interfaces for asyncio"
7 url="https://github.com/vxgmichel/aioconsole"
8 license=('GPL')
9 arch=('any')
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-asyncio' 'python-pytest-cov' 'python-pytest-repeat')
13 source=("https://github.com/vxgmichel/aioconsole/archive/v$pkgver/$pkgname-$pkgver.tar.gz.tar.gz")
14 sha512sums=('ab3f6ac1e0a79418b0941a0c1a48b906703e5e9097a8e9643cf8be5e30d9b5fa74108e6a739104a854328e33a039396b41011f9ba5ca9a7d64f105f4bd50cf7a')
16 build() {
17   cd aioconsole-$pkgver
18   python setup.py build
21 check() {
22   cd aioconsole-$pkgver
23   python -m pytest
26 package() {
27   cd aioconsole-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1