archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-cx-freeze / repos / community-x86_64 / PKGBUILD
blob613a689eb83e005329aa2dd3619d3d1cb0b275a7
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Alexander Rødseth <rodseth@gmail.com>
3 # Contributor: Ray Rashif <schiv@archlinux.org>
4 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
5 # Contributor: Eric Belanger <eric@archlinux.org>
6 # Contributor: Roberto Alsina <ralsina@kde.org>
7 # Contributor: Julien Duponchelle <julien@gns3.net>
9 pkgname=python-cx-freeze
10 pkgver=6.12.0
11 pkgrel=2
12 pkgdesc='Create standalone executables from Python scripts'
13 arch=('x86_64')
14 url='https://marcelotduarte.github.io/cx_Freeze'
15 license=('PSF')
16 depends=('patchelf' 'python-packaging' 'python-setuptools')
17 checkdepends=('python-pytest-mock' 'python-bcrypt' 'python-cryptography' 'python-openpyxl'
18               'python-pandas' 'python-pillow' 'python-pydantic' 'python-pytz')
19 replaces=('python-cx_freeze')
20 provides=('python-cx_freeze')
21 conflicts=('python-cx_freeze')
22 source=("https://github.com/marcelotduarte/cx_Freeze/archive/$pkgver/$pkgname-$pkgver.tar.gz")
23 sha512sums=('a3fdd94b33985b3bb0fbee2fc7438e20f3ddb31f0d71322eed1c06a15954be5845a0b1dfbc55537fe16022db95b446d3fa0b3e8418cd250e653f42a180b8c586')
25 build() {
26   cd cx_Freeze-$pkgver
27   python setup.py build
30 check() {
31   cd cx_Freeze-$pkgver
32   python setup.py egg_info
33   # TODO
34   PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-310" python -m pytest --deselect tests/test_command_bdist_rpm.py::test_bdist_rpm
37 package() {
38   cd cx_Freeze-$pkgver
39   python setup.py install --root "$pkgdir" --optimize 1 --skip-build