archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-dpkt / repos / community-any / PKGBUILD
blobe62443b8ad270485cb22bfba7be4b95416a626d6
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 _pyname=dpkt
4 pkgname=python-${_pyname}
5 pkgver=1.9.8
6 pkgrel=2
7 pkgdesc='Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols'
8 url='https://github.com/kbandla/dpkt'
9 arch=('any')
10 license=('custom')
11 depends=('python')
12 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
13 source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
14 sha512sums=('fd0edcca00f3b4ec4da2345ce1efc6da5ac372f39e8d0dd5fa25c2482ab3a9e37f8954dccf5230920c038272decd854abb4fcc8ddbdbbea721c49ce88ffe69d3')
15 b2sums=('c9ab5503339f6465e799250b7bd482c5bc06a022c19436b9ec334306a7bceb8232274d0ca397614717e19ffd5fdece3760ea7c3cc49703a1a47d55050546da75')
17 build() {
18   cd "${_pyname}-${pkgver}"
19   python -m build --wheel --no-isolation
22 package() {
23   cd "${_pyname}-${pkgver}"
24   python -m installer --destdir="$pkgdir" dist/*.whl
25   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
26   install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
29 # vim: ts=2 sw=2 et: