archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-graphql-relay / repos / community-any / PKGBUILD
blob0030351b9641fb1397b4f2328e1e22d24a424604
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=python-graphql-relay
4 pkgver=3.2.0
5 pkgrel=2
6 pkgdesc='A library to help construct a graphql-py server supporting react-relay'
7 url=https://github.com/graphql-python/graphql-relay-py
8 arch=(any)
9 license=(MIT)
10 depends=(
11   python-graphql-core
12   python-promise
13   python-six
15 makedepends=(
16   git
17   python-setuptools
19 _tag=97ba15e573eabcefd13e249d05fc5557f0296804
20 source=(git+https://github.com/graphql-python/graphql-relay-py.git#tag=${_tag})
21 sha256sums=(SKIP)
23 pkgver() {
24   cd graphql-relay-py
26   git describe --tags | sed 's/^v//'
29 build() {
30   cd graphql-relay-py
32   python setup.py build
35 package() {
36   cd graphql-relay-py
38   python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
39   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-graphql-relay/
42 # vim: ts=2 sw=2 et: