1 # Maintainer: Bruno Pagani <archange@archlinux.org>
7 pkgdesc="krb5 API interface"
9 url="https://github.com/jborean93/pykrb5"
12 makedepends=(cython python-setuptools)
13 checkdepends=(python-pytest python-k5test)
14 # No tests in pypi tarball
15 #source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
16 source=(${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
17 sha256sums=('9660773e64a205e59c61272ee7783b58f4617129e23a7c313b4e2210bf98f823')
20 cd py${_pkg}-${pkgver}
25 cd py${_pkg}-${pkgver}
26 local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
27 PYTHONPATH="${PWD}"/build/lib.linux-$CARCH-cpython-${python_version/./} pytest -vv --color=yes
31 cd py${_pkg}-${pkgver}
32 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
33 install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}