1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-latex2mathml
6 pkgdesc="Pure Python library for LaTeX to MathML conversion"
7 url="https://github.com/roniemartinez/latex2mathml"
10 depends=('python-setuptools')
11 makedepends=('python-build' 'python-installer' 'python-poetry-core')
12 checkdepends=('python-pytest' 'python-multidict' 'python-xmljson')
13 source=("https://github.com/roniemartinez/latex2mathml/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('bf2d0e54f0d7640818cbfd27238a9fd9471ecbf591566b685d729d9596eca0574cbf43cc5c642947dc2f780e1990095ac7d814ccb31062a25b81b0ffea67c04e')
17 cd latex2mathml-$pkgver
18 sed -i '/--cov/d' pyproject.toml
22 cd latex2mathml-$pkgver
27 cd latex2mathml-$pkgver
32 cd latex2mathml-$pkgver
33 python -m installer -d "$pkgdir" dist/*.whl
34 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/