archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-nest-asyncio / trunk / PKGBUILD
blob238fc79346619ed451aca230cb4fb5fa36230e42
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-nest-asyncio
4 pkgver=1.5.6
5 pkgrel=2
6 pkgdesc="Patch asyncio to allow nested event loops"
7 url="https://github.com/erdewit/nest_asyncio"
8 license=('BSD')
9 arch=('any')
10 depends=('python')
11 makedepends=('python-setuptools')
12 provides=('python-nest_asyncio')
13 replaces=('python-nest_asyncio')
14 source=("https://github.com/erdewit/nest_asyncio/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
15 sha512sums=('3dbfe5362a31dcd3e579e30164a51d9cd8dcb5507667fa454a6375bbd0a1cca209df01cf99424e8e424685d617c0524888784f3672c8e9454de4cea07daeca03')
17 build() {
18   cd nest_asyncio-$pkgver
19   python setup.py build
22 check() {
23   cd nest_asyncio-$pkgver
24   PYTHONPATH="$PWD/build/lib" python tests/nest_test.py
27 package() {
28   cd nest_asyncio-$pkgver
29   python setup.py install --root="$pkgdir" --optimize=1
31   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/