1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=python-openapi-core
7 pkgdesc='Client-side and server-side support for the OpenAPI Specification v3'
9 url='https://github.com/p1c2u/openapi-core'
11 depends=(python-openapi-spec-validator python-werkzeug python-isodate python-more-itertools)
12 makedepends=(python-build python-installer python-poetry-core)
13 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
14 sha256sums=('561b7e2b37b336e9c62d4634b9059d12d9bb2e1859062a39d3a0fa6afc8c9de6')
18 python -m build --wheel --no-isolation
23 python -m installer --destdir="$pkgdir" dist/*.whl
24 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname