archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-openapi-core / trunk / PKGBUILD
blob04426fffa9c7da26c050850bcd5587b51d5034a6
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=python-openapi-core
4 _pipname=openapi_core
5 pkgver=0.17.1
6 pkgrel=5
7 pkgdesc='Client-side and server-side support for the OpenAPI Specification v3'
8 arch=(any)
9 url='https://github.com/p1c2u/openapi-core'
10 license=(BSD)
11 depends=(python-openapi-spec-validator python-werkzeug python-isodate python-more-itertools)
12 makedepends=(python-build python-installer python-poetry-core)
13 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
14 sha256sums=('561b7e2b37b336e9c62d4634b9059d12d9bb2e1859062a39d3a0fa6afc8c9de6')
16 build() {
17   cd $_pipname-$pkgver
18   python -m build --wheel --no-isolation
21 package() {
22   cd $_pipname-$pkgver
23   python -m installer --destdir="$pkgdir" dist/*.whl
24   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname