1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A Python 2/3 compatibility layer for C extensions"
7 url="https://github.com/encukou/py3c"
11 makedepends=('python-setuptools')
12 source=("$pkgname-$pkgver.tar.gz::https://github.com/encukou/py3c/archive/v$pkgver.tar.gz")
13 sha512sums=('db71db2c19a16ba5a430b676beb357faee5b67b161478932af13dd06be23b5505da85dbaf5b2447f95590fea55b833ee33fa19d3350ba3117f3364a9ab012ee6')
17 # Don't regenerate with broken path in "install" target
18 sed -i 's/install: py3c.pc/install:/' Makefile
24 make prefix=/usr py3c.pc
34 make prefix="$pkgdir"/usr install
35 python setup.py install --root="$pkgdir" --optimize=1
37 # Remove headers in broken location
38 rm -r "$pkgdir"/usr/include/python*
40 install -Dm644 LICENSE.MIT -t "$pkgdir"/usr/share/licenses/$pkgname/