archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-pylast / repos / community-any / PKGBUILD
blob946bf1a6a445c6e46cb6abdcaf6ffc39b8f24da5
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Steven Allen <steven@stebalien.com>
3 # Contributor: Limao Luo <luolimao+AUR@gmail.com>
4 # Contributor: Wieland Hoffmann <the_mineo@web.de>
5 # Contributor: Amr Hassan <amr.hassan@gmail.com>
7 pkgname=python-pylast
8 pkgver=5.1.0
9 pkgrel=2
10 pkgdesc='A Python interface to Last.fm and Libre.fm'
11 arch=(any)
12 url='https://github.com/pylast/pylast'
13 license=(Apache)
14 depends=(
15   python-httpx
16   python-importlib-metadata
18 makedepends=(
19   git
20   python-build
21   python-hatch-vcs
22   python-hatchling
23   python-installer
25 _tag=ce76c03581511499cf3d2163e0465c9aa05141a9
26 source=(git+https://github.com/pylast/pylast.git#tag=${_tag})
27 sha256sums=(SKIP)
29 pkgver() {
30   cd pylast
31   git describe --tags
34 build() {
35   cd pylast
36   python -m build --wheel --no-isolation
39 package() {
40   python -m installer --destdir="${pkgdir}" pylast/dist/*.whl
43 # vim: ts=2 sw=2 et: