archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-slugify / repos / community-any / PKGBUILD
blobcf7df108a7407981fd2c151f667a5cdc45d66fc9
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Thomas Jost <schnouki@schnouki.net>
3 # Contributor: Andrey Mikhaylenko <neithere@gmail.com>
5 pkgname=python-slugify
6 pkgver=8.0.1
7 pkgrel=2
8 pkgdesc='A Python slugify application that handles unicode'
9 arch=(any)
10 url=https://github.com/un33k/python-slugify
11 license=(MIT)
12 depends=(python-text-unidecode)
13 makedepends=(
14   git
15   python-setuptools
17 optdepends=('python-unidecode: Unidecode support')
18 _tag=58031becacdc8945393ddf628e84a6785cd08066
19 source=(git+https://github.com/un33k/python-slugify.git#tag=${_tag})
20 sha256sums=(SKIP)
22 pkgver() {
23   cd python-slugify
25   git describe --tags | sed 's/^v//;s/-/+/g'
28 build() {
29   cd python-slugify
31   python setup.py build
34 package() {
35   cd python-slugify
37   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
38   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-slugify/
41 # vim: ts=2 sw=2 et: