archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / qjackctl / trunk / PKGBUILD
blob4e0cab3f9ed5227c3e7a65992a288cef70ca18d0
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Ray Rashif <schiv@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@archlinux.org>
5 pkgname=qjackctl
6 pkgver=0.9.10
7 pkgrel=1
8 pkgdesc="A Qt front-end for the JACK low-latency audio server"
9 arch=(x86_64)
10 url="https://qjackctl.sourceforge.io"
11 license=(GPL2)
12 groups=(pro-audio)
13 depends=(
14   gcc-libs
15   glibc
16   hicolor-icon-theme
17   qt6-base
18   qt6-svg
20 makedepends=(
21   alsa-lib
22   cmake
23   jack2
24   jack2-dbus
25   qt6-tools
26   portaudio
28 optdepends=(
29   'jack2-dbus: for JACK dbus support'
30   'qt6-wayland: for native wayland support'
32 source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
33 sha512sums=('e209b1814ac2ea0b2d885d7f265b515f95f8f94acb19c6475a0cc37073ca099d7c6ac4949c646b49ffcf0e38a188ea5587dfae54b350d0df5eae9600615b7645')
34 b2sums=('923310e8f6541ae8c0c463a2f256c3f960a45c1025608a9b5712873983243498178541dda4ca08dc0558b35765ec0abab48fef9ee727963bea57cae82285f146')
36 build() {
37   local cmake_options=(
38     -B build
39     -D CMAKE_BUILD_TYPE=None
40     -D CMAKE_INSTALL_PREFIX=/usr
41     -D CONFIG_QT6=ON
42     -S $pkgname-$pkgver
43     -W no-dev
44   )
46   cmake "${cmake_options[@]}"
47   cmake --build build --verbose
50 package() {
51   depends+=(
52     alsa-lib libasound.so
53     jack libjack.so
54     portaudio libportaudio.so
55   )
57   DESTDIR="$pkgdir" cmake --install build
58   install -vDm 644 $pkgname-$pkgver/{ChangeLog,README,TRANSLATORS} -t "$pkgdir/usr/share/doc/$pkgname"