archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / sparsehash / repos / community-any / PKGBUILD
blob35680699b769639069f46429fc2925a8ff3cde7e
1 # Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
3 pkgname=sparsehash
4 pkgver=2.0.4
5 pkgrel=2
6 pkgdesc="Library that contains several hash-map implementations, including implementations that optimize for space or speed."
7 arch=("any")
8 url="https://github.com/sparsehash/sparsehash"
9 options=('debug')
10 license=('BSD')
11 source=("https://github.com/sparsehash/sparsehash/archive/sparsehash-$pkgver.tar.gz")
12 sha256sums=('8cd1a95827dfd8270927894eb77f62b4087735cbede953884647f16c521c7e58')
14 build() {
15         cd "$srcdir"/sparsehash-sparsehash-$pkgver
16         ./configure --prefix=/usr
17         make
20 package() {
21         cd "$srcdir"/sparsehash-sparsehash-$pkgver
22         make DESTDIR="$pkgdir/" install
23         install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING