archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / unarchiver / repos / community-x86_64 / PKGBUILD
blobf1bd2a02ecfbda928ef9aa9b0dfd6b6eb37e4409
1 # Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
2 # Contributor: Cedric Girard <girard.cedric@gmail.com>
3 # Contributor: N30N <archlinux@alunamation.com>
5 pkgname=unarchiver
6 pkgver=1.10.7
7 _UniversalDetector_pkgver=1.1
8 pkgrel=8
9 pkgdesc="unar and lsar: Objective-C tools for uncompressing archive files"
10 arch=(x86_64)
11 url="https://github.com/MacPaw/XADMaster"
12 license=('LGPL2.1')
13 depends=(gnustep-base openssl bzip2 icu gcc-libs zlib wavpack)
14 makedepends=(gcc-objc gnustep-make)
15 source=("XADMaster-${pkgver}.tar.gz::https://github.com/MacPaw/XADMaster/archive/v${pkgver}.tar.gz"
16         "UniversalDetector-${_UniversalDetector_pkgver}.tar.gz::https://github.com/MacPaw/universal-detector/archive/${_UniversalDetector_pkgver}.tar.gz"
17         "native_obj_exceptions.patch")
18 sha256sums=('3d766dc1856d04a8fb6de9942a6220d754d0fa7eae635d5287e7b1cf794c4f45'
19             '8e8532111d0163628eb828a60d67b53133afad3f710b1967e69d3b8eee28a811'
20             '7592fb0f689e588ad9a6caee522eabe8bc64659eb71bb8629239856e79d3c757')
22 prepare() {
23   # The project requires UniversalDetector next to the source dir. See the project's README for more info about the build requirements.
24   ln -s universal-detector-${_UniversalDetector_pkgver} UniversalDetector
26   cd "$srcdir/XADMaster-${pkgver}"
27   patch < ../native_obj_exceptions.patch
30 build() {
31   cd "$srcdir/XADMaster-${pkgver}"
33   . /usr/share/GNUstep/Makefiles/GNUstep.sh
34   make -f Makefile.linux
37 package() {
38   cd "$srcdir/XADMaster-${pkgver}"
39   install -d "$pkgdir/usr/bin/"
40   install -m755 unar lsar "$pkgdir/usr/bin/"
42   install -d "$pkgdir/usr/share/man/man1"
43   install -m644 Extra/{lsar.1,unar.1} "$pkgdir/usr/share/man/man1/"
44   install -d "$pkgdir/usr/share/bash-completion/completions/"
45   install -m644 Extra/unar.bash_completion "$pkgdir/usr/share/bash-completion/completions/unar"
46   install -m644 Extra/lsar.bash_completion "$pkgdir/usr/share/bash-completion/completions/lsar"