archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / unbound / trunk / PKGBUILD
blob982c4fa85dead90c9de821ef25137078fe89164b
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Maintainer: T.J. Townsend <blakkheim@archlinux.org>
4 # Contributor: Gaetan Bisson <bisson@archlinux.org>
5 # Contributor: Hisato Tatekura <hisato_tatekura@excentrics.net>
6 # Contributor: Massimiliano Torromeo <massimiliano DOT torromeo AT google mail service>
8 pkgname=unbound
9 pkgver=1.17.1
10 pkgrel=2
11 pkgdesc="Validating, recursive, and caching DNS resolver"
12 arch=(x86_64)
13 url="https://unbound.net/"
14 license=(BSD)
15 depends=(dnssec-anchors fstrm hiredis ldns libnghttp2 libsodium)
16 makedepends=(expat libevent openssl protobuf-c python swig systemd)
17 optdepends=(
18   'expat: for unbound-anchor'
19   'sh: for unbound-control-setup'
20   'python: for python-bindings'
22 provides=(libunbound.so)
23 backup=(etc/$pkgname/$pkgname.conf)
24 source=(
25   https://unbound.net/downloads/$pkgname-$pkgver.tar.gz{,.asc}
26   $pkgname-1.14.0-trust_anchor_file.patch
27   $pkgname-sysusers.conf
28   $pkgname-tmpfiles.conf
29   $pkgname-trusted-key.hook
31 sha512sums=('10dd4c3aff77f1c0d19eb3c66956ed6ef1aae19e827d0b3259dc75d9de28dedd41862982a299e67ee07e17fb52058b4beee9d4b1d3bb0a3f633b9ba5b864d168'
32             'SKIP'
33             '9590d3d459d96f99cbc7482fae0f5318dd22a034e45cff18079e4f3c9f9c3c1d7af90cdd5353fb469eac08c535555fd164097b496286b807b2117e8a3a6cd304'
34             'ef71d4e9b0eb0cc602d66bd0573d9424578fe33ef28a852c582d56f0fd34fdd63046c365ef7aed8b84a461b81254240af7ad3fd539da72f9587817d21bd6c585'
35             '6b1849ae9d7cf427f6fa6cd0590e8f8c3f06210d2d6795e543b0f325a9e866db0f5db2275a29fa90f688783c0dd16f19c8a49a9817d5f5444e13f8f2df3ff712'
36             '613826cdf5ab6e77f2805fa2aa65272508dcd11090add1961b3df6dfac3b67db016bc9f45fbcf0ef0de82b2d602c153d5263a488027a6cf13a72680b581b266d')
37 b2sums=('c2dec1608e28302da33ee72144bb8eb16cdff2e949e548f9ea5edb10b370e396085de641446b1f94daeb96a48a02f9361ebae69f72f3d449575fe3ce93dcdb5b'
38         'SKIP'
39         '0978ab5c0474ed29de9c0904a46d114413e094dafeadaac4f10cdbc19e4152fcc064d7cdb8c331da7c2531075aa699326b84e21da1a8218a6f00a10f0e107b3d'
40         '292a3c2e5fde292a03b6c9b2ddabd5089f52e73b50a404c3d9f54c1a43184924b661a21eea61cc521c594c1005a3b40b630fa585a38195c61298f9b24b248b92'
41         'd3951006b43068be904c6b91a9e0563d56228225854e12b40abbdd4ba9b47338e97265837297a6de879acbc8051bb749163f9457683f5e12fc29ac2e7b687fd3'
42         'd28785390eb6c125bd26ca11f097fe8864b080482157deeb7c70e9bee47ff2844abaed574db59a7c152ed3ec0acba05cfee4c3751f7a9f553320b064578f86c7')
43 validpgpkeys=(EDFAA3F2CA4E6EB05681AF8E9F6F1C2D7E045F8D) # W.C.A. Wijngaards <wouter@nlnetlabs.nl>
45 prepare() {
46   # enable trusted-anchor-file and set it to an unbound specific location
47   patch -p1 -d $pkgname-$pkgver -i ../$pkgname-1.14.0-trust_anchor_file.patch
48   cd $pkgname-$pkgver
49   autoreconf -fiv
52 build() {
53   local configure_options=(
54     --prefix=/usr
55     --sysconfdir=/etc
56     --localstatedir=/var
57     --sbindir=/usr/bin
58     --disable-rpath
59     --enable-dnscrypt
60     --enable-dnstap
61     --enable-pie
62     --enable-relro-now
63     --enable-subnet
64     --enable-systemd
65     --enable-tfo-client
66     --enable-tfo-server
67     --enable-cachedb
68     --with-libhiredis
69     --with-conf-file=/etc/unbound/unbound.conf
70     --with-pidfile=/run/unbound.pid
71     --with-rootkey-file=/etc/trusted-key.key
72     --with-libevent
73     --with-libnghttp2
74     --with-pyunbound
75   )
77   cd $pkgname-$pkgver
78   ./configure "${configure_options[@]}"
79   # prevent excessive overlinking due to libtool
80   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
81   make
84 check() {
85   make -k check -C $pkgname-$pkgver
88 package() {
89   depends+=(
90     libevent libevent-2.1.so
91     openssl libcrypto.so libssl.so
92     protobuf-c libprotobuf-c.so
93     systemd-libs libsystemd.so
94   )
96   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
97   install -vDm 644 $pkgname-$pkgver/contrib/$pkgname.service -t "$pkgdir/usr/lib/systemd/system/"
98   install -vDm 644 $pkgname-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
99   install -vDm 644 $pkgname-sysusers.conf "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
100   install -vDm 644 $pkgname-tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
101   # libalpm hook to copy the dnssec-anchors provided key to /etc/unbound
102   install -vDm 644 unbound-trusted-key.hook -t "$pkgdir/usr/share/libalpm/hooks/"