archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / unp / repos / community-any / PKGBUILD
blobccc398be34065647e0d29ef4ba95842429eca57e
1 # Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
2 # Contributor: Michael Düll <mail@akurei.me> PGP-Key: AAAEE882
3 # Contributor: TDY <tdy@gmx.com>
4 # Contributor: Sergio Rubio <rubiojr.ml@gmail.com>
5 # Contributor: Hannes Rist <cowider@gmail.com>
6  
7 pkgname=unp
8 _ver=2.0~pre10
9 pkgver="${_ver//[~]/.}"
10 pkgrel=1
11 pkgdesc='A script for unpacking a wide variety of archive formats'
12 arch=(any)
13 url="https://tracker.debian.org/pkg/unp"
14 license=(GPL2)
15 depends=(perl)
16 optdepends=(
17   'unarj: arj support'
18   'unrar: rar support'
19   'unzip: zip support'
20   'bzip2: bzip2 support'
21   'p7zip: p7zip support'
22   'unace: ace support'
23   'cpio: cpio support'
24   'sharutils: sharutils'
25   'cabextract: cab support'
26   'rpmextract: rpm support'
28 source=("https://ftp.debian.org/debian/pool/main/u/unp/unp_${_ver}.tar.xz")
29 sha512sums=('3f8f9f20eef88658b4b00efd37208d859fb3220178f9446696f755a864fea3c3dd301100668bd9c97ca9312ebe961aaf9ec523d8817b8aacb5a1ee6a36213666')
30 b2sums=('63d8c995091a1342677b6aed5854293c582cb6d42c6748ef3d92347ca75e1d3e9e5b128309299ec0b6fc0361bc14dededcc8e290fe8721aecfe82665e07998e9')
32 prepare() {
33   mv -v "${pkgname}-${_ver}" "${pkgname}-${pkgver}"
36 build() {
37   cd unp-$pkgver/po
38   make
41 package() {
42   cd unp-$pkgver
43   install -Dm755 unp "$pkgdir"/usr/bin/unp
44   install -Dm755 ucat "$pkgdir"/usr/bin/ucat
45   install -Dm644 debian/unp.1 "$pkgdir"/usr/share/man/man1/unp.1
46   install -Dm755 debian/unp.bash-completion "$pkgdir"/usr/share/bash-completion/completions/unp
48   cd po
49   make DESTDIR="$pkgdir" install