1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alexandre Bouvier <contact@amb.tf>
7 pkgdesc='Nintendo Switch emulator'
9 url=https://yuzu-emu.org/
49 _tag=3da9b31ccc4b773c13303a5fb3498f806b0fa000
51 git+https://github.com/yuzu-emu/yuzu-mainline.git#tag=${_tag}
52 git+https://github.com/arsenm/sanitizers-cmake.git
53 git+https://github.com/yhirose/cpp-httplib.git
54 git+https://github.com/arun11299/cpp-jwt.git
55 git+https://github.com/mozilla/cubeb.git
56 git+https://github.com/MerryMage/dynarmic.git
57 yuzu-mbedtls::git+https://github.com/yuzu-emu/mbedtls.git
58 yuzu-sirit::git+https://github.com/yuzu-emu/sirit.git
59 git+https://github.com/herumi/xbyak.git
73 git config submodule.cpp-httplib.url "${srcdir}"/cpp-httplib
74 git config submodule.cpp-jwt.url "${srcdir}"/cpp-jwt
75 git config submodule.cubeb.url "${srcdir}"/cubeb
76 git config submodule.dynarmic.url "${srcdir}"/dynarmic
77 git config submodule.mbedtls.url "${srcdir}"/yuzu-mbedtls
78 git config submodule.sirit.url "${srcdir}"/yuzu-sirit
79 git config submodule.xbyak.url "${srcdir}"/xbyak
80 git -c protocol.file.allow=always submodule update
82 git config submodule.cmake/sanitizers-cmake.url "${srcdir}"/sanitizers-cmake
83 git -c protocol.file.allow=always submodule update
88 git describe --tags | sed 's/.*-//'
92 cmake -S yuzu-mainline -B build -G Ninja \
93 -DCMAKE_BUILD_TYPE=None \
94 -DCMAKE_INSTALL_PREFIX=/usr \
95 -DBUILD_REPOSITORY=yuzu-emu/yuzu-mainline \
96 -DBUILD_TAG=${pkgver} \
97 -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
99 -DENABLE_QT_TRANSLATION=ON \
101 -DENABLE_WEB_SERVICE=ON \
102 -DSIRIT_USE_SYSTEM_SPIRV_HEADERS=ON \
103 -DTITLE_BAR_FORMAT_IDLE="yuzu | ${pkgver} {}" \
104 -DTITLE_BAR_FORMAT_RUNNING="yuzu | ${pkgver} | {}" \
105 -DUSE_DISCORD_PRESENCE=OFF \
106 -DYUZU_CHECK_SUBMODULES=OFF \
107 -DYUZU_USE_BUNDLED_FFMPEG=OFF \
108 -DYUZU_USE_BUNDLED_QT=OFF \
109 -DYUZU_USE_BUNDLED_SDL2=OFF \
110 -DYUZU_USE_EXTERNAL_VULKAN_HEADERS=OFF \
111 -DYUZU_USE_EXTERNAL_SDL2=OFF \
112 -DYUZU_USE_FASTER_LD=OFF \
113 -DYUZU_USE_PRECOMPILED_HEADERS=OFF \
114 -DYUZU_USE_QT_MULTIMEDIA=ON \
115 -DYUZU_USE_QT_WEB_ENGINE=ON \
122 DESTDIR="${pkgdir}" cmake --install build