archrelease: copy trunk to community-any
[ArchLinux/community.git] / acme-user / repos / community-any / PKGBUILD
blobe80d73e5b9ef38f5d36c33587d455ca08814e18d
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 pkgname=acme-user
4 pkgver=1.0.1
5 pkgrel=1
6 pkgdesc="acme-tiny systemd files for running as dedicated user instead of root."
7 arch=(any)
8 url="https://github.com/ArchangeGabriel/acme-user"
9 license=(GPL)
10 depends=(acme-tiny systemd)
11 source=(${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.zst{,.asc})
12 sha256sums=(bbc14de2b86d4ebaa2c3559de92df42beac556a96d098fce5d9ac75a9a8cb933 SKIP)
13 validpgpkeys=(69DA34D78FE0EFD596AC6D049D893EC4DAAF9129)
15 package() {
16   install -Dm755 acme-renew.sh "${pkgdir}"/usr/bin/acme-renew
17   install -Dm755 acme-post.sh "${pkgdir}"/usr/bin/acme-post
18   install -Dm644 acme.{service,timer} -t "${pkgdir}"/usr/lib/systemd/system/
19   install -Dm644 acme.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/acme.conf
20   install -Dm644 acme.sysusers "${pkgdir}"/usr/lib/sysusers.d/acme.conf