archrelease: copy trunk to community-any
[ArchLinux/community.git] / alsa-scarlett-gui / repos / community-x86_64 / PKGBUILD
blob82e251a45dad2d8fce194e71e26b7defe73b49e5
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=alsa-scarlett-gui
4 pkgver=0.2
5 pkgrel=2
6 pkgdesc='GUI for the ALSA controls presented by the Focusrite Scarlett Gen 2/3 mixer driver'
7 arch=('x86_64')
8 url='https://github.com/geoffreybennett/alsa-scarlett-gui'
9 license=('GPL3' 'LGPL3')
10 depends=('gtk4' 'alsa-lib')
11 makedepends=('git')
12 _commit='d085fd49c1a8ef3dda348d06b1d7381adccaaf2f'
13 source=("$pkgname::git+$url#commit=$_commit")
14 b2sums=('SKIP')
16 pkgver() {
17   cd "$pkgname"
19   git describe --tags | sed 's/^v//'
22 prepare() {
23   cd "$pkgname"
25   # remove incorrect keys in desktop file
26   sed \
27     -i src/vu.b4.alsa-scarlett-gui.desktop.template \
28     -e '/^Value=.*/d' \
29     -e '/^Encoding=.*/d'
32 build() {
33   cd "$pkgname"
35   make \
36     -C src \
37     PREFIX=/usr \
38     VERSION="$pkgver"
41 package() {
42   cd "$pkgname"
44   make \
45     -C src \
46     PREFIX="$pkgdir/usr" \
47     VERSION="$pkgver" \
48     install
50   # documentation
51   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.md
52   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname/img" img/*
53   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname/demo" demo/*