archrelease: copy trunk to community-any
[ArchLinux/community.git] / antic / trunk / PKGBUILD
blob18b2c01147d44ed23092dcae8aaed2880e078c26
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=antic
4 pkgver=0.2.5
5 pkgrel=1
6 pkgdesc='Algebraic Number Theory In C'
7 arch=(x86_64)
8 url='https://github.com/wbhart/antic'
9 license=(LGPL)
10 depends=(flint)
11 makedepends=()
12 source=(https://github.com/wbhart/antic/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('7b236b6226d5730cf66d492f1562c34d4dcf1bdc8775fec2330f560332ab05c1')
15 build() {
16   cd $pkgname-$pkgver
17   ./configure --prefix=/usr --with-flint=/usr --with-gmp=/usr --with-mpfr=/usr
19   make
22 check() {
23   cd $pkgname-$pkgver
24   make check
27 package() {
28   cd $pkgname-$pkgver
29   make DESTDIR="$pkgdir" install