archrelease: copy trunk to community-any
[ArchLinux/community.git] / aspell-uk / trunk / PKGBUILD
blob058b6209cd03fb788127defdb65e86073f245d7d
1 # Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
2 # Contributor: Roman Kyrylych <roman@archlinux.org>
4 pkgname=aspell-uk
5 pkgver=1.8.0
6 _ftpver=1.4.0
7 pkgrel=3
8 pkgdesc="Ukrainian dictionary for aspell"
9 arch=('x86_64')
10 url="http://ispell-uk.sourceforge.net/"
11 license=('GPL' 'LGPL' 'MPL')
12 depends=('aspell')
13 source=(https://ftp.gnu.org/gnu/aspell/dict/uk/aspell6-uk-${_ftpver}-0.tar.bz2
14         https://downloads.sourceforge.net/project/ispell-uk/spell-uk/$pkgver/spell-uk-$pkgver.tgz
15         aspell-uk-perl-5.26.patch)
16 sha256sums=('35f9a7e840c1272706bc6dd172bc9625cbd843d021094da8598a6abba525f18c'
17             '111e5b945254df4e140922d10daa3da2beffe05d389c1cb2e1e436298f23f2b5'
18             '736c05603a361cd31ff045f2669e8fd8cdaa7ec6222bc328d1ad9310d422e609')
20 prepare() {
21   cd spell-uk-$pkgver
22   patch -p1 -i ../aspell-uk-perl-5.26.patch # Fix build with perl 5.26
25 build() {
26   # needed when using a source package from ispell-uk project
27   cd "${srcdir}"/spell-uk-$pkgver
28   make
30   cd "${srcdir}"/aspell6-uk-${_ftpver}-0
31   ./configure
32   make
34   # needed when using a source package from ispell-uk project
35   #mv ${srcdir}/spell-uk-$pkgver/dist/aspell-uk-$pkgver/* \
36   #  ${srcdir}/aspell6-uk-${_ftpver}-0
39 package() {
40   cd "${srcdir}"/aspell6-uk-${_ftpver}-0
42   make DESTDIR="$pkgdir" install