archrelease: copy trunk to community-any
[ArchLinux/community.git] / aws-c-auth / repos / community-x86_64 / PKGBUILD
blob15dbbbb487fbd6ab44098e86fe09ec0f5d43140b
1 # Maintainer: Anatol Pomozov
3 pkgname=aws-c-auth
4 pkgver=0.6.26
5 pkgrel=1
6 pkgdesc='C99 library implementation of AWS client-side authentication: standard credentials providers and signing'
7 arch=(x86_64)
8 url='https://github.com/awslabs/aws-c-auth'
9 license=(Apache)
10 depends=(aws-c-common aws-c-http aws-c-sdkutils)
11 makedepends=(cmake)
12 source=(aws-c-auth-$pkgver.zip::https://github.com/awslabs/aws-c-auth/archive/v$pkgver.zip)
13 sha256sums=('b539a4a24eca72fd76a852e863816b9eee4688541904678ccb8162351e637ca2')
15 build() {
16   cd aws-c-auth-$pkgver
18   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -S . -B build
19   cmake --build build
22 check() {
23   cd aws-c-auth-$pkgver
24   cmake --build build --target test
27 package() {
28   cd aws-c-auth-$pkgver
30   cmake --build build --target install -- DESTDIR="$pkgdir/"
31   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"