1 # Maintainer: Anatol Pomozov
6 pkgdesc='Core c99 package for AWS SDK for C. Includes cross-platform primitives, configuration, data structures, and error handling.'
8 url='https://github.com/awslabs/aws-c-common'
12 source=(aws-c-common-$pkgver.zip::https://github.com/awslabs/aws-c-common/archive/v$pkgver.zip)
13 sha256sums=('85fb290789068fc58ab067b4db2db46b81a46ea5311f6bced9dd539b9ea94582')
16 cd aws-c-common-$pkgver
18 cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -S . -B build
23 cd aws-c-common-$pkgver
24 cmake --build build --target test
28 cd aws-c-common-$pkgver
30 cmake --build build --target install -- DESTDIR="$pkgdir/"
31 install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"